Ad Hoc Vulnerability Scan (new requirement) ()